
MS Word 

Here are the answers to the 100 frequently asked questions about Microsoft Word: 

General Questions 

1. What is Microsoft Word? 

➢ Microsoft Word is a word processing software that allows users to create, edit, format, and share text 

documents. 

2. What are the main features of MS Word? 

➢ Main features include text formatting, templates, document sharing, spell-checking, grammar-

checking, Track Changes, collaboration tools, and the ability to insert multimedia like tables, images, 

and hyperlinks. 

3. How can I open Microsoft Word on my computer? 

➢ You can open MS Word by searching for "Word" in the Start Menu (Windows) or Applications 

folder (Mac) or clicking the Word icon on your desktop/taskbar. 

4. What are the system requirements for MS Word? 

➢ MS Word requires a modern Windows or Mac operating system, at least 4 GB of RAM, and a few 

GB of storage. It is also available on mobile platforms like Android and iOS. 

5. Is Microsoft Word free? 

➢ Microsoft Word is not free, but you can use it with a Microsoft 365 subscription or through a free 

online version at Office.com. 

6. How can I buy Microsoft Word? 

➢ You can purchase Word as part of a Microsoft 365 subscription or buy a one-time license of Office. 

It can be purchased through the Microsoft Store or authorized retailers. 

7. Can I use Microsoft Word on a Mac? 

➢ Yes, Microsoft Word is available for Mac as part of Microsoft 365 or as a standalone application. 



8. Does Microsoft Word have a web version? 

➢ Yes, you can use Microsoft Word online for free by visiting Office.com and signing in with a 

Microsoft account. 

9. Can I use Microsoft Word on mobile devices? 

➢ Yes, MS Word is available as a mobile app for both Android and iOS devices, offering basic word 

processing features. 

10. What are the file formats supported by MS Word? 

➢ MS Word supports formats like .docx, .doc, .pdf, .txt, .rtf, and .odt, among others. 

Basic Usage 

11. How do I create a new document in MS Word? 

➢ Open MS Word and click on "New Document" or use the shortcut Ctrl + N (Windows) or Cmd + N 

(Mac). 

12. How do I save a document in Word? 

➢ Click "File" > "Save As" to name and save the document. The shortcut is Ctrl + S (Windows) or 

Cmd + S (Mac). 

13. How do I open an existing document? 

➢ Click "File" > "Open" and browse for the file you want to open, or use the shortcut Ctrl + O 

(Windows) or Cmd + O (Mac). 

14. How do I print a Word document? 

➢ Click "File" > "Print," or press Ctrl + P (Windows) or Cmd + P (Mac) to access printing options. 

15. How do I close a document in MS Word? 

➢ Click "File" > "Close," or use the shortcut Ctrl + W (Windows) or Cmd + W (Mac). 

16. What is the default file format for saving documents in Word? 

➢ The default file format is .docx. 



17. How do I copy and paste text in MS Word? 

➢ Select the text, right-click, and choose "Copy," then right-click and select "Paste" where you want 

the text. You can also use Ctrl + C to copy and Ctrl + V to paste (Cmd for Mac). 

18. How do I undo or redo changes in Word? 

➢ To undo, use Ctrl + Z (Windows) or Cmd + Z (Mac). To redo, use Ctrl + Y (Windows) or Cmd + 

Y (Mac). 

19. How do I select text in a document? 

➢ Click and drag the mouse over the text or use Shift and arrow keys on the keyboard. 

20. How do I check word count in MS Word? 

➢ Click on "Review" > "Word Count" or check the word count displayed in the status bar at the bottom 

of the document. 

Formatting and Layout 

21. How do I change the font in Word? 

➢ Select the text, then use the Font dropdown in the Home tab to change the font style and size. 

22. How do I adjust line spacing in MS Word? 

➢ Select the text, then click on the Line and Paragraph Spacing button in the Home tab and choose the 

desired spacing option. 

23. How do I create a bulleted or numbered list? 

➢ Click on the Bullets or Numbering icon in the Home tab, or use the shortcut Ctrl + Shift + L for 

a bulleted list. 

24. How do I change the page orientation (portrait/landscape)? 

➢ Go to "Layout" > "Orientation," and choose either "Portrait" or "Landscape." 

25. How do I insert a header or footer? 

➢ Go to "Insert" > "Header" or "Footer," then select a built-in design or create your own. 



26. How do I create a table in Word? 

➢ Go to "Insert" > "Table," then select the number of rows and columns you need. 

27. How do I adjust margins in Word? 

➢ Go to "Layout" > "Margins," and select one of the predefined margin settings or customize your 

own. 

28. How do I change paragraph alignment in Word? 

➢ Select the paragraph, then click on the alignment buttons (left, center, right, justify) in the Home tab. 

29. How do I insert a page break? 

➢ Go to "Insert" > "Page Break," or use the shortcut Ctrl + Enter (Windows) or Cmd + Enter 

(Mac). 

30. How do I format text as bold, italic, or underlined? 

➢ Select the text and click on the Bold (B), Italic (I), or Underline (U) buttons in the Home tab, or use 

the shortcuts Ctrl + B, Ctrl + I, or Ctrl + U (Cmd for Mac). 

Advanced Features 

31. What is Track Changes, and how do I use it? 

➢ Track Changes allows you to see edits and suggestions made to a document. Turn it on by going to 

"Review" > "Track Changes." 

32. How do I use comments in a document? 

➢ Select the text and go to "Review" > "New Comment" to add a comment in the margin. 

33. How do I insert images into my document? 

➢ Go to "Insert" > "Pictures" to add an image from your computer or online. 

34. How do I insert hyperlinks in MS Word? 

➢ Select the text, then go to "Insert" > "Link" and enter the URL or link to another part of the 

document. 



35. What is a table of contents, and how do I create one? 

➢ A table of contents lists the sections of a document and their page numbers. Go to "References" > 

"Table of Contents" to insert one automatically. 

36. How do I use templates in Word? 

➢ Go to "File" > "New" to browse and select a pre-designed template for documents like resumes, 

reports, and letters. 

37. What are Word Styles, and how do I use them? 

➢ Styles are predefined text formats (e.g., headings, titles). Apply them by selecting text and choosing 

a style from the Styles group in the Home tab. 

38. How do I create a form in MS Word? 

➢ Go to "Developer" tab (enable from options if not visible), and use tools like checkboxes, text boxes, 

and drop-down lists to create forms. 

39. How do I insert a watermark in a Word document? 

➢ Go to "Design" > "Watermark" to add a custom or built-in watermark to the background of your 

document. 

40. How do I create footnotes and endnotes? 

➢ Go to "References" > "Insert Footnote" or "Insert Endnote" to add them to your document. 

Page Layout and Design 

41. How do I insert a cover page in MS Word? 

➢ Go to "Insert" > "Cover Page" and choose from the available designs. 

42. How do I adjust page size in Word? 

➢ Go to "Layout" > "Size" and select the page size (e.g., Letter, A4) from the dropdown. 

43. How do I use columns in a Word document? 

➢ Go to "Layout" > "Columns," and select the number of columns you'd like to use. 



44. How do I insert shapes and SmartArt in Word? 

➢ Go to "Insert" > "Shapes" for shapes, and "SmartArt" for diagrams and flowcharts. 

45. How do I wrap text around images in Word? 

➢ Select the image, go to "Format" > "Wrap Text," and choose how text should wrap around it (e.g., 

square, tight, behind text). 

46. What is WordArt, and how do I use it? 

➢ WordArt is a feature that allows you to create stylized text. Go to "Insert" > "WordArt" and select a 

style. 

47. How do I create and modify text boxes? 

➢ Go to "Insert" > "Text Box" to insert a text box. You can move and resize it as needed. 

48. How do I insert a table of figures in Word? 

➢ Go to "References" > "Insert Table of Figures" to automatically create a list of figures based on their 

captions. 

49. How do I change the background color of a page? 

➢ Go to "Design" > "Page Color" and select the desired color. 

50. How do I use themes and styles in Word? 

➢ Go to "Design" > "Themes" to apply a theme to your document, which includes a set of fonts, colors, 

and effects. 

Collaboration and Sharing 

51. How do I share a Word document? 

➢ Click "File" > "Share" and choose how to share (e.g., via email, OneDrive, or as a link). 

52. How do I collaborate on a Word document in real-time? 

➢ Upload the document to OneDrive or SharePoint, then share it with others. Multiple people can edit 

it simultaneously. 



53. What is OneDrive, and how does it integrate with Word? 

➢ OneDrive is Microsoft’s cloud storage service. You can save and share Word documents directly to 

OneDrive for easy access and collaboration. 

54. How do I protect a document with a password? 

➢ Go to "File" > "Info" > "Protect Document" and select "Encrypt with Password." 

55. How do I restrict editing in a Word document? 

➢ Go to "File" > "Info" > "Protect Document" > "Restrict Editing" to limit who can edit the document. 

56. How do I compare two versions of a document? 

➢ Go to "Review" > "Compare" to compare and highlight differences between two versions of a 

document. 

57. How do I convert a Word document to PDF? 

➢ Go to "File" > "Save As" and choose PDF from the "Save as type" dropdown. 

58. Can I recover unsaved Word documents? 

➢ Yes, go to "File" > "Info" > "Manage Document" > "Recover Unsaved Documents" to restore 

unsaved files. 

59. How do I export a Word document to other formats (e.g., HTML, ODT)? 

➢ Go to "File" > "Save As" and choose the desired file format from the "Save as type" dropdown. 

60. How do I send a Word document as an email attachment? 

➢ Go to "File" > "Share" > "Email," and choose to send the document as an attachment. 

Document Navigation and Editing 

61. How do I use the navigation pane in Word? 

➢ Go to "View" > "Navigation Pane" to open the panel that helps you navigate headings, pages, and 

search results in the document. 

62. How do I find and replace text in Word? 



➢ Press Ctrl + H (Windows) or Cmd + H (Mac) to open the Find and Replace dialog. 

63. How do I add bookmarks to a document? 

➢ Go to "Insert" > "Bookmark," name the bookmark, and add it to the document for easy navigation. 

64. How do I create hyperlinks to specific sections of a document? 

➢ Highlight the text, go to "Insert" > "Link," and choose to link to a bookmark or heading within the 

document. 

65. How do I insert symbols or special characters? 

➢ Go to "Insert" > "Symbol" and select from the available symbols or special characters. 

66. How do I use keyboard shortcuts in Word? 

➢ You can use a variety of shortcuts like Ctrl + C to copy, Ctrl + V to paste, Ctrl + Z to undo, and 

many others. A full list can be found under Word's Help menu. 

67. How do I use the thesaurus and dictionary in Word? 

➢ Right-click a word and select "Synonyms" or go to "Review" > "Thesaurus" for suggestions. You 

can also use "Define" for dictionary definitions. 

68. How do I insert citations and bibliographies in Word? 

➢ Go to "References" > "Insert Citation" to add a citation and "Bibliography" to insert a list of sources. 

69. How do I merge Word documents? 

➢ Copy content from one document and paste it into another, or use the "Insert" > "Object" > "Text 

from File" option. 

70. How do I split a Word document into sections? 

➢ Use "Layout" > "Breaks" > "Section Break" to divide a document into separate sections with 

different layouts or formatting. 

Graphics and Media 

71. How do I insert videos into a Word document? 



➢ Go to "Insert" > "Online Video" to embed videos from sources like YouTube or Vimeo. 

72. How do I insert charts and graphs in Word? 

➢ Go to "Insert" > "Chart" to add various types of charts. Data for the chart can be edited in an Excel 

window that appears. 

73. How do I edit images in MS Word? 

➢ Select the image, then use the "Picture Tools" toolbar to adjust brightness, contrast, crop, or apply 

styles. 

74. How do I add captions to images, tables, or other objects? 

➢ Select the object, right-click, and choose "Insert Caption" to add a descriptive label. 

75. How do I use the drawing tools in Word? 

➢ Go to "Insert" > "Shapes" to add drawings. You can also enable "Draw" tab for freehand drawing 

using touch or stylus devices. 

76. How do I insert and manage 3D models in Word? 

➢ Go to "Insert" > "3D Models" to insert models from online sources or your device. You can rotate 

and scale them as needed. 

77. How do I insert Excel data or charts in Word? 

➢ Go to "Insert" > "Table" or "Insert" > "Chart" and select "From Excel Spreadsheet" to insert data or 

charts from Excel. 

78. How do I link or embed files in Word documents? 

➢ Go to "Insert" > "Object" and choose whether to embed or link another file (such as a PDF or Excel 

sheet) within your Word document. 

79. How do I insert audio in a Word document? 

➢ Go to "Insert" > "Object" > "Audio File" to add an audio file (this is not always supported in all 

versions). 

80. How do I use Word with PowerPoint? 



➢ You can copy and paste text or use "Insert" > "Object" > "From File" to embed PowerPoint slides 

into a Word document. 

Troubleshooting 

81. Why is my document not saving in Word? 

➢ This could be due to a lack of storage space, file corruption, or insufficient permissions. Try saving 

to a different location or format. 

82. How do I recover a corrupted Word document? 

➢ Try opening the document in "Open and Repair" mode via "File" > "Open." You can also attempt to 

recover text by selecting "Recover Text from Any File." 

83. Why is Word running slowly? 

➢ This may be due to large file sizes, too many add-ins, or insufficient computer resources. Try 

disabling add-ins, closing other programs, or repairing Office. 

84. Why is Word not responding or crashing? 

➢ Restart Word, check for software updates, disable add-ins, and try running Word in safe mode. If 

problems persist, reinstall the application. 

85. How do I fix formatting issues in Word? 

➢ Use the "Clear Formatting" option under the Home tab to reset the text to its default style. Also, 

check for hidden formatting symbols using Ctrl + Shift + 8. 

86. Why can't I edit a document in Word? 

➢ The document may be in Read-Only mode, protected, or you might not have editing permissions. 

Check the document properties under "File" > "Info." 

87. How do I fix issues with Word templates? 

➢ Ensure the template is not corrupted. Try re-saving the template or downloading a new copy. You 

can also try reapplying the template to the document. 

88. Why is my Word document opening in Read-Only mode? 



➢ The document may be marked as final or protected. Go to "File" > "Info" and check if editing 

restrictions are enabled. 

89. How do I restore the default settings in Word? 

➢ Go to "File" > "Options" > "General" and reset preferences. You can also reinstall Word or reset the 

Normal.dotm template to its default state. 

90. How do I fix issues with Track Changes not working properly? 

➢ Make sure Track Changes is turned on and check the display settings. Also, ensure that no 

conflicting settings are applied under "Review" > "Track Changes Options." 

Integration and Customization 

91. How do I integrate MS Word with other Microsoft Office apps? 

➢ Word integrates with other Office apps like Excel and PowerPoint. You can copy data between apps 

or use features like mail merge and OLE (Object Linking and Embedding). 

92. How do I customize the Quick Access Toolbar? 

➢ Go to "File" > "Options" > "Quick Access Toolbar" to add or remove commands. 

93. How do I change the language in Word? 

➢ Go to "File" > "Options" > "Language" to set the display language, editing language, and proofing 

tools language. 

94. How do I enable or disable macros in Word? 

➢ Go to "File" > "Options" > "Trust Center" > "Trust Center Settings" > "Macros" to enable or disable 

macro functionality. 

95. How do I create a custom Word template? 

➢ Customize a document, then go to "File" > "Save As" and choose "Word Template" (.dotx) as the 

file type. 

96. How do I use Mail Merge in Word? 



➢ Go to "Mailings" > "Start Mail Merge" and follow the steps to combine a document with a data 

source (e.g., Excel) to create personalized letters or labels. 

97. How do I use add-ins with Word? 

➢ Go to "Insert" > "Get Add-ins" to browse and install add-ins that extend Word’s functionality. 

98. Can I automate tasks in Word? 

➢ Yes, you can use macros to automate repetitive tasks. Macros are created by recording actions or 

writing Visual Basic for Applications (VBA) code. 

99. How do I change the default font and style in Word? 

➢ Go to "Home" > "Styles" > "Modify Style" to set a new default font or style for new documents. 

100. How do I update Microsoft Word?  

➢ Go to "File" > "Account" > "Update Options" to check for and install updates for Microsoft Word 

and other Office apps. 

These answers cover a wide range of MS Word functionalities, troubleshooting, and advanced features to 

help users improve their experience with the software. 

 

Most Important FAQs 

Here are some of the most important questions and answers related to Microsoft Word: 

1. What is Microsoft Word and its primary use? 

Answer: Microsoft Word is a widely-used word processing software that allows users to create, edit, and format text 
documents such as letters, reports, resumes, and more. 

2. How do I save a document in Word? 

Answer: To save a document, click on "File" > "Save" or use the shortcut Ctrl + S (Windows) or Cmd + S (Mac). 
To save with a different name or location, choose "Save As." 

3. What is the default file format for Word documents? 

Answer: The default file format is .docx, which is an XML-based format for Word documents. 

4. How do I change the font and text size in Word? 



Answer: Highlight the text you want to modify, then go to the Home tab and use the Font dropdown to change the 
font style and the Size dropdown to adjust the text size. 

5. How do I add page numbers to my document? 

Answer: Go to "Insert" > "Page Number," and select where you want the page numbers to appear (top, bottom, 
etc.). 

6. How do I insert a table into a Word document? 

Answer: Go to "Insert" > "Table," then select the number of rows and columns needed for your table, or draw a 
custom table. 

7. What is the purpose of "Track Changes" in Word? 

Answer: "Track Changes" allows users to track edits made to a document by highlighting additions, deletions, and 
format changes. It is often used for collaboration and reviewing documents. 

8. How do I create a bulleted or numbered list? 

Answer: Highlight the text you want to turn into a list, then go to the Home tab and click on either the Bullets or 
Numbering icons. 

9. How do I insert a hyperlink in Word? 

Answer: Select the text or object you want to hyperlink, then go to "Insert" > "Link" and enter the URL or link to 
another document section. 

10. How can I convert a Word document to PDF? 

Answer: Go to "File" > "Save As," and select PDF from the list of available file formats, then click "Save." 

11. How do I change the page orientation (Portrait/Landscape)? 

Answer: Go to "Layout" > "Orientation," and select either "Portrait" or "Landscape." 

12. What is the difference between "Save" and "Save As"? 

Answer: "Save" updates the existing document with any changes, while "Save As" allows you to save a new copy of 
the document, possibly in a different location or with a different name. 

13. How do I check spelling and grammar in Word? 

Answer: Go to the "Review" tab and click "Spelling & Grammar" to automatically check and correct spelling and 
grammar issues. 

14. How do I insert headers and footers? 

Answer: Go to "Insert" > "Header" or "Footer," then choose a predefined layout or customize your own. 

15. How can I protect a document with a password? 

Answer: Go to "File" > "Info" > "Protect Document," and select "Encrypt with Password." Enter and confirm the 
password to protect the document. 



These questions and answers provide a foundation for working effectively in Microsoft Word. 

 

 

Most Advanced FAQs: 

Here are some advanced questions and answers related to Microsoft Word, focusing on features that go 

beyond the basics: 

 

1. How can I create and apply custom styles in Word? 

Answer: To create a custom style, go to the "Home" tab, click on the arrow in the "Styles" group, and select "Create 
a Style." Name your style, define the formatting options, and click "OK." You can then apply this style to text by 
selecting it from the Styles gallery. 

2. What is the difference between section breaks and page breaks? 

Answer: A page break moves text to the next page, whereas a section break divides the document into sections, 
allowing different formatting (e.g., margins, headers/footers, or page orientation) for each section. You can insert 
these by going to "Layout" > "Breaks." 

3. How do I create a table of contents in Word? 

Answer: Use built-in heading styles (e.g., Heading 1, Heading 2) for your section titles. Then, go to "References" > 
"Table of Contents" and choose a style. Word will automatically generate a table of contents based on your 
headings. 

4. How do I perform a mail merge in Word? 

Answer: Go to "Mailings" > "Start Mail Merge," select the document type (e.g., letters, emails), then use "Select 
Recipients" to choose your data source (like an Excel file). Insert merge fields, then click "Finish & Merge" to 
generate the final documents. 

5. How can I create a cross-reference in Word? 

Answer: Place your cursor where you want the cross-reference. Go to "Insert" > "Cross-reference." In the dialog box, 
choose what type of item you’re referencing (e.g., headings, figures, tables), then select the specific item. This 
creates a dynamic link to that item. 

6. How do I create and manage templates in Word? 

Answer: To create a template, design a document as needed and go to "File" > "Save As." Choose "Word Template 
(*.dotx)" from the file type options. Templates can be reused by selecting them from "File" > "New" > "Personal" in 
Word. 

7. How do I insert and format a watermark in Word? 

Answer: Go to "Design" > "Watermark." Choose from built-in watermarks or create a custom one by selecting 
"Custom Watermark" where you can add text or an image as the watermark. 



8. How do I use macros to automate tasks in Word? 

Answer: Go to "View" > "Macros" > "Record Macro." Perform the tasks you want to automate, and then stop 
recording. You can run the macro later by going back to "View" > "Macros" > "View Macros" and selecting the one 
you recorded. You can also write advanced macros using VBA (Visual Basic for Applications). 

9. How do I link or embed an Excel spreadsheet into Word? 

Answer: Go to "Insert" > "Object" > "Create from File" and select your Excel file. You can choose to link the file 
(which will update automatically if the Excel file changes) or embed it (which creates a static copy). 

10. How do I manage document versions in Word? 

Answer: Word automatically saves different versions of a document. You can access these by going to "File" > "Info" 
> "Version History." From there, you can view or restore previous versions of the document. 

11. How do I create a master document and subdocuments in Word? 

Answer: A master document helps organize long documents by splitting them into smaller subdocuments. Go to 
"View" > "Outline," click "Show Document," and then use the "Create" button to add subdocuments. This allows you 
to manage large projects in smaller, more manageable parts. 

12. How can I customize and use fields in Word? 

Answer: Fields are placeholders for dynamic data (e.g., date, author, file name). Go to "Insert" > "Quick Parts" > 
"Field," select a field type (e.g., "Date"), and insert it into your document. Fields can be updated by right-clicking and 
selecting "Update Field." 

13. How do I use content controls in Word forms? 

Answer: Content controls allow you to create fillable forms. Go to "Developer" tab (enable this via "File" > "Options" 
> "Customize Ribbon"), and insert content controls like text boxes, checkboxes, or drop-down lists. You can lock the 
form so users can only fill in specific fields. 

14. How do I create a citation and bibliography using Word’s referencing tools? 

Answer: Go to "References" > "Insert Citation" to add sources. You can manage the bibliography and choose citation 
styles (APA, MLA, etc.) from the "References" tab. Use "Bibliography" to automatically generate a list of sources at 
the end of the document. 

15. How do I use Word’s co-authoring and collaboration features? 

Answer: Upload your document to OneDrive or SharePoint, then share it with others via "File" > "Share." Multiple 
people can edit the document simultaneously, and their changes will appear in real-time. 

16. How do I use bookmarks to navigate a large document? 

Answer: Place your cursor where you want to create a bookmark, go to "Insert" > "Bookmark," name the bookmark, 
and click "Add." To navigate to the bookmark later, go to "Insert" > "Bookmark," select the bookmark, and click "Go 
To." 

17. How can I review and merge comments from multiple reviewers? 



Answer: Go to "Review" > "Show Markup" > "Comments" to see all comments. Use the "Compare" tool under 
"Review" > "Compare" to merge comments and track changes from different versions of the document. 

18. How can I create footnotes and endnotes in Word? 

Answer: Go to "References" > "Insert Footnote" or "Insert Endnote." Footnotes appear at the bottom of the page, 
while endnotes appear at the end of the document. 

19. How do I handle large files in Word to avoid performance issues? 

Answer: Use techniques such as dividing the document into sections, compressing images, or linking to external 
data. Consider using master documents and subdocuments for very large projects. 

20. How do I create and manage fields for cross-referencing in Word? 

Answer: Use fields like bookmarks, captions, or table references for cross-referencing. Insert a cross-reference via 
"Insert" > "Cross-reference," then choose the field type (e.g., bookmark, figure) to link. 

 

These advanced questions and answers delve deeper into Microsoft Word’s powerful features, making it 

easier to handle complex tasks and customize your workflow. 

 

 

 

Interview Related FAQs: 

Here are some important Microsoft Word interview questions along with their answers. These questions 

cover a range of topics, from basic knowledge to more advanced features, which are often asked in 

interviews for roles requiring proficiency in MS Word. 

1. What is Microsoft Word and what are its primary uses? 

Answer: Microsoft Word is a word processing application developed by Microsoft. It is primarily used for creating, 
editing, and formatting text-based documents such as letters, reports, memos, and resumes. It includes various tools 
for document layout, text formatting, spell checking, and collaboration. 

2. What is the default file format for Microsoft Word documents? 

Answer: The default file format for Microsoft Word is .docx, which is an XML-based document format that ensures 
better compatibility, smaller file sizes, and improved file recovery. 

3. How do you create a Table of Contents in Word? 

Answer: To create a Table of Contents, first, apply heading styles (e.g., Heading 1, Heading 2) to the sections of your 
document. Then, go to the "References" tab and click on "Table of Contents." Choose a built-in style, and Word will 
automatically generate the Table of Contents based on the applied heading styles. 

4. What is the difference between ‘Save’ and ‘Save As’ in Word? 



Answer: The "Save" option updates the existing document with any changes, while the "Save As" option allows you 
to save the document under a new name or in a different location or format, such as PDF or an older version of 
Word. 

5. How can you insert and format a table in Word? 

Answer: To insert a table, go to the "Insert" tab and click on "Table." You can either select the number of rows and 
columns or use the "Insert Table" option to specify the dimensions. After inserting the table, you can format it by 
using the "Table Design" and "Layout" tabs to change borders, shading, and alignment. 

6. What are section breaks and how are they used in Word? 

Answer: Section breaks in Word are used to divide a document into sections, allowing different formatting (such as 
headers, footers, margins, and page orientation) for each section. You can insert a section break by going to "Layout" 
> "Breaks" and selecting from the options like "Next Page," "Continuous," etc. 

7. How do you track changes in Word and what is its use? 

Answer: To track changes, go to the "Review" tab and click "Track Changes." This feature highlights all edits made to 
the document, making it easier to review modifications, especially in collaborative environments. Users can accept 
or reject changes and add comments. 

8. How do you perform a Mail Merge in Word? 

Answer: To perform a Mail Merge, go to the "Mailings" tab, click "Start Mail Merge," and choose the document type 
(e.g., letters, emails). Then, click "Select Recipients" to connect to a data source (like an Excel sheet) and insert 
merge fields for personalized data (e.g., names and addresses). After that, finish the merge by clicking "Finish & 
Merge." 

9. What is a macro in Word, and how is it used? 

Answer: A macro in Word is a recorded sequence of actions that automates repetitive tasks. You can create a macro 
by going to "View" > "Macros" > "Record Macro." Perform the actions you want to automate, then stop recording. 
Macros can be run later to repeat the actions automatically. 

10. How can you insert a hyperlink in a Word document? 

Answer: To insert a hyperlink, highlight the text or object you want to link, go to the "Insert" tab, and click on "Link." 
In the dialog box, you can enter a URL, or link to a file or another place in the same document (e.g., a heading or 
bookmark). 

11. What are styles in Word, and how can you use them? 

Answer: Styles in Word are pre-defined formatting options for text, including font, size, color, alignment, and 
spacing. To apply a style, select the text and choose a style from the "Styles" group on the Home tab. You can also 
create and modify custom styles by clicking "Create a Style." 

12. How do you protect a Word document with a password? 

Answer: To protect a document with a password, go to "File" > "Info" > "Protect Document" and select "Encrypt with 
Password." Enter and confirm your password. This ensures that only users with the correct password can open the 
document. 

13. What is a watermark, and how do you insert one in Word? 



Answer: A watermark is a faint design or text that appears behind the content on each page, often used for branding 
or indicating the document's status (e.g., "Confidential"). To insert a watermark, go to the "Design" tab, click 
"Watermark," and choose a built-in option or create a custom watermark. 

14. What is the difference between footnotes and endnotes in Word? 

Answer: Footnotes appear at the bottom of the page, while endnotes appear at the end of the document or section. 
Both are used to provide additional information or citations. You can insert them from the "References" tab by 
selecting either "Insert Footnote" or "Insert Endnote." 

15. How do you format page numbers in Word? 

Answer: To format page numbers, go to "Insert" > "Page Number," and choose the position (top or bottom of the 
page). You can further customize the format by selecting "Format Page Numbers," where you can change the 
numbering style (e.g., Roman numerals) or start numbering from a specific point. 

16. How can you convert a Word document into a PDF? 

Answer: To convert a Word document to PDF, go to "File" > "Save As," choose the location, and select "PDF" from 
the dropdown menu in the file type list. Click "Save" to generate the PDF file. 

17. How do you insert a header and footer in a Word document? 

Answer: To insert a header or footer, go to the "Insert" tab and click either "Header" or "Footer." Choose from the 
built-in options or create a custom one. You can include text, page numbers, and other elements in headers and 
footers. 

18. What is the difference between linking and embedding objects in Word? 

Answer: When you link an object (like an Excel chart), the object updates automatically when the source file is 
changed. When you embed an object, it becomes a static part of the Word document and does not update with 
changes in the source file. 

19. How do you use bookmarks in Word? 

Answer: Bookmarks mark specific locations in your document for easy navigation. To create a bookmark, place the 
cursor where you want to add it, go to "Insert" > "Bookmark," name the bookmark, and click "Add." You can jump to 
a bookmark by using the "Go To" feature in the "Find" dialog box. 

20. How can you collaborate on a Word document using OneDrive or SharePoint? 

sAnswer: Upload the document to OneDrive or SharePoint, then share it with others by clicking "File" > "Share." 
Multiple users can work on the document simultaneously, and Word will show changes in real-time, along with the 
name of the user making the edits. 

These questions cover both basic and advanced features of Microsoft Word, and can help candidates prepare 

for interviews where proficiency with Word is required. 

 


